Абсолютные и относительные ссылки в Эксель

ЛогоМногие уверенные в себе пользователи умеют пользоваться редактором Эксель. Но не все понимают, чем отличаются абсолютные и относительные ссылки. В данной статье мы постараемся вам продемонстрировать эту разницу на конкретных примерах. Благодаря инструкции с этой задачей смогут разобраться даже пользователи, только начинающие знакомиться с Excel.

Для начала нужно сделать какую-нибудь таблицу. Это и будет наше рабочее пространство.

Рабочее пространство

Использование относительных ссылок

В качестве примера будем использовать самую простую и популярную функцию в Excel – сумма ячеек. Для создания этой формулы вам необходимо:

  1. Перейти в какую-нибудь ячейку.
  2. Ввести следующее выражение.
=СУММ(B3:G3)

Ввод формулы

  1. Нажать на клавишу Enter.
  2. В результате этого редактор посчитает сумму всех значений, которые находятся в ячейках от «B3» до «G3».

«B3» до «G3»

  1. Продублируйте это выражение в остальные ячейки.

Размножение

  1. Вы увидите, что произошла замена номеров строк. То есть вначале мы указывали диапазон ячеек «B3:G3», а теперь редактор автоматически изменил их на «B5:G5».

B3 G3

Данный тип адресов называется относительным из-за того, что при копировании формулы происходит корректировка индексов относительно того, куда именно вы переместились. То есть, если вы скопировали содержимое клетки на 2 строки ниже, то и в выражении произойдут изменения на 2 строки. То же самое происходит и со столбцами.

Смешанный тип

Данный вид ссылок отличается тем, что вы можете зафиксировать какой-нибудь элемент (строку или колонку). Использовать его можно следующим образом.

  1. Перейдите на другую клетку.
  2. Теперь введите то же самое выражение, только на этот раз его нужно немного изменить.
=СУММ(B$3:G$3)

Как видите, зафиксированная строка обозначается символом доллара.

Смешанный тип

  1. В результате быстрого расчета вы увидите тот же самый результат.

Результат

  1. Теперь нужно скопировать эту формулу в остальные ячейки.

Копирование

  1. Как видите, результат вычислений везде оказался одинаковым. Дело в том, что при копировании функции у нас адрес не менялся. Несмотря на то, что мы переносили эти настройки на другие строки, нужная позиция в формуле оставалась неизменной.

Одинаковый итог

  1. Обратите внимание на то, что мы фиксировали только строку. Теперь попробуйте скопировать эту ячейку в другую колонку. Для этого необходимо нажать на сочетание клавиш Ctrl+C.

Копирование данных

  1. Затем её нужно вставить рядом нажатием на горячие клавиши Ctrl+V.

Результат будет другой. Строка осталась та же, но колонки сдвинулись. То есть теперь в адресе участвуют другие столбцы – от «С» до «H». Хотя изначально были от «B» до «G».

«С» до «H»

Использование абсолютных ссылок

Для того чтобы подобные проблемы не возникали, используется абсолютный тип адресов. В этом случае от вас потребуется выполнение следующих действий.

  1. Измените формулу в ячейке со смешанным адресом на следующий код.
=СУММ($B$3:$G$3)

=СУММ($B$3 $G$3)

  1. Скопируйте новое содержимое при помощи кнопок Ctrl+С.

Копирование кнопками

  1. Теперь вставьте содержимое буфера обмена в соседнюю клетку. Для этого нужно нажать на горячие клавиши Ctrl+V.
  2. Вы увидите, что результат не изменился.

Один и тот же результат

  1. Попробуйте в качестве теста скопировать эту ячейку в любое место в открытой книге.
  2. Формула и результат будут одинаковыми.

Формула и результат

То есть, если вам необходимо, чтобы при копировании формула оставалась точь-в-точь, как в оригинале, нужно использовать абсолютные ссылки. Для этого перед каждой буквой и цифрой ставится символ доллара.

Заключение

В этой статье мы постарались подробно рассказать, чем могут отличаться относительные и абсолютные ссылки в Excel. Также было уделено особое внимание практической ценности использования того или иного типа адресов, поскольку у каждого формата есть своё предназначение.

Описанные выше методы помогут вам самостоятельно выполнить:

  • обычные задания по информатике (как в классе, так и дома);
  • сложные отчеты по работе;
  • различные презентации и многое другое.

Стоит отметить, что данный принцип работы одинаковый во всех версиях редактора Microsoft Excel (2016, 2013, 2010, 2007 и 2003 годов).

Если вдруг у вас что-то не получается, возможно, вы допускаете какую-нибудь ошибку. Например, поставили знак доллара в неправильном месте или вообще забыли про него.

Видеоинструкция

Именно для таких случаев (когда у кого-то возникли проблемы), мы подготовили видеоролик, в котором все описанные выше инструкции рассказываются более подробно с дополнительными комментариями.

Читайте также:

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Adblock detector