Как посчитать сумму значений столбца в Эксель

ЛогоExcel – мощный редактор для работы с большим объемом данных и ведения различных расчётов при помощи формул. Но как правило, не каждый пользователь знает про все возможности, которые есть в этой программе. Например, как в Excel посчитать сумму в столбце. Некоторые по незнанию используют для этого калькулятор. В данной статье будут рассмотрены различные формулы, которые могут пригодиться большинству офисных работников.

Автосуммирование

Для демонстрации возможностей этой функции, нужно будет сделать следующие действия.

  1. Первым делом следует создать какую-нибудь простую таблицу с несколькими значениями. Разместим их всех в один столбик.

Простая таблица

  1. Затем выделите все ячейки. После этого нажмите на иконку «Суммы», расположенную в правой части панели инструментов.

Выделение ячеек

  1. В результате этого редактор автоматически посчитает сумму и выведет ее на следующей строке.

Результат работы

Для того чтобы вывести итоговый результат в отдельном месте, нужно сделать немного иные действия.

  1. Кликните на какую-нибудь ячейку.
  2. Снова нажмите на иконку «Суммы».

Клик по ячейке

  1. В результате этого Эксель предложит сосчитать всё то, что находится выше. Но там ведь находятся и пустые ячейки.

Пустые ячейки

  1. Поэтому выделяем только те, которые нам нужны, иначе будут считаться и пустые значения (в момент выделения ваш курсор примет вид белого крестика).

Выделение

  1. Для того чтобы изменения вступили в силу, нужно нажать на клавиатуре на клавишу Enter.

Применение изменений

Строка состояния

Существует еще один очень простой способ. Узнать общую сумму значений в ячейках можно обычным выделением. Как только вы это сделаете, результат отобразится в строке состояния, расположенной в нижней части программы.

Результат выделения

Кроме этого, мы увидим количество элементов и их среднее значение.

Количество элементов

Минус данного метода в том, что результат сложения на листе нигде не выводится.

Использование функций

Найти сумму цифр в ячейках можно и при помощи формул. Делается это следующим образом.

  1. Кликните на какую-нибудь ячейку.
  2. Перейдите в строку ввода уравнений.

Клик по любой ячейке

  1. Введите там следующий текст.
=СУММ(
  1. В результате этого у вас появится подсказка, что дальше нужно вводить числа.

Подсказка

  1. Укажите там диапазон ячеек, в которых находятся значения. Вводить нужно сначала букву, а потом цифру.

Указание диапазона

  1. Либо вы можете просто выделить эти ячейки.

Простое выделение

  1. В итоге должно получиться следующее.
=СУММ(C4:C9)

Итог

  1. Далее нажмите на клавиатуре на клавишу Enter. Только после этого вы сможете узнать результат.

Нажатие на Enter

Преимущество данного метода в том, что вы можете вручную указывать выборочный диапазон ячеек.

Суммирование произведений двух столбцов

Иногда на практике нужно вывести не просто сумму, но еще сделать дополнительные математические действия в разных колонках. Например, как в представленном случае.

Суммирование

Для вывода общей суммы необходимо сделать следующие действия.

  1. Сделайте активной нужную ячейку.
  2. Кликните на строку ввода формулы.

Вывод суммы

  1. Напишите следующую команду.
=СУММ(
  1. Выделите вручную значения в одной из колонок. Например, в нашем случае выделим столбец «Количество».

Запись команды

Если в формуле автоматически не появится закрывающая скобка, ее нужно будет добавить вручную.

  1. Затем сдвигаемся в формуле правее и ставим символ «*» (знак умножения). Если вы работаете на ноутбуке, то нужно будет нажать на сочетание клавиш Shift+8.

Знак умножения

  1. После этого пишем еще раз следующий код.
=СУММ(

Еще раз пишем код

  1. На этот раз выделяем другой столбец.

Выделение другого столбца

  1. Обязательно проверяем наличие закрывающей скобки.

Закрывающая скобка

Для завершения нужно нажать на клавишу Enter. В результате этого вы увидите сумму произведения двух столбцов.

Завершение

Сумма с одним условием

Так же бывают случаи, когда нужно складывать не всё подряд, а лишь некоторую часть ячеек. Для этого нужно использовать дополнительные условия, которые будут служить аналогом фильтра значений.

Проверку можно делать как по числовому, так и по текстовому формату данных. Рассмотрим оба случая.

Текстовое значение

  1. Для начала добавим в таблице новую строку для вычислений.

Сумма с одним условием

  1. Перейдите в нужную ячейку. Затем кликните на строку ввода формул.

Переход на нужную ячейку

  1. Введите там следующую команду.
=СУММЕСЛИ(
  1. В результате этого редактор Excel выведет вам подсказку, что нужно сначала указать диапазон значений, затем критерий отбора и в конце сам диапазон суммирования.

Ввод команды

  1. Выделяем сначала колонку, по которой будем делать проверку. В нашем случае это столбец «Статус», в котором есть два состояния – «пусто» и «продано».

Выделение колонки

  1. После выделения обязательно добавляем символ «;» (точка с запятой), иначе будет ошибка в формуле. Затем пишем слово, по которому будем делать фильтр. В нашем случае это «Продано». Писать необходимо в кавычках. Это обязательно. Разумеется, после этого снова ставим символ «;».

После выполнения

  1. Теперь выделяем тот столбец, по которому будут происходить расчеты.

Выделение столбца

  1. Добавляем закрывающую скобку «)».

Добавление закрывающей скобки

  1. Для проверки работы формулы нажимаем на клавиатуре на клавишу Enter. В результате описанных выше действий должны посчитаться значения только тех ячеек, напротив которых написано слово «Продано».

Проверка

Это очень удобно, особенно если в вашем отчете огромное количество информации.

Численное значение

В этом случае для проверки будем использовать графу «Стоимость». Для расчета выполним следующие действия.

  1. Добавим еще одну строку, в которой будем выводить «Количество дорогих товаров».

Стоимость

  1. Перейдите в нужную ячейку. После этого начните вводить эту же функцию.
=СУММЕСЛИ(

Переход в нужную ячейку

  1. В качестве условия выделяем столбец «Стоимость».

Стоимость товара

  1. Обязательно дописываем символ «;». Только после этого можно будет перейти к следующему аргументу.

Дописывание символа

  1. Затем в кавычках указываем «>20». Это условие означает – считать всё то, что больше 20. Здесь используются обычные математические операторы – всё как в школе. В конце снова ставим символ «;».

Указание значения

  1. Только теперь можно указать столбец, в котором будут производиться расчёты.

Выбор столбца

  1. Ставим закрывающую скобку «)».

Закрывающая скобка в конце

  1. Для проверки результата нажимаем на клавиатуре кнопку Enter.

Проверка результата

Благодаря этому мы смогли найти количество всех дорогих товаров. Таким же способом можно посчитать что угодно. Всё зависит от условия.

Сумма с несколькими условиями

Но иногда всё намного сложней. Например, могут быть случаи, когда нужно посчитать в столбце сумму всех одновременно и дорогих, и проданных продуктов. Рассмотрим, как правильно составить формулу для этой ситуации.

  1. Сначала добавим новую строку.

Добавление очередной строки

  1. Выделяем нужную ячейку и переходим в строку ввода функций.

Выделение ячейки

  1. На этот раз вводим другую формулу.
=СУММЕСЛИМН(

Буквы МН означают, что будет использовано много условий.

У этой функции аргументы расположены в ином порядке (в отличие от СУММЕСЛИ).

СУММЕСЛИ

  1. Здесь мы сразу выделяем тот столбец, в котором указано количество товаров. В прошлый раз мы это делали в последнюю очередь – здесь всё наоборот.

Выделение нужного столбца

  1. Обязательно закрываем аргумент точкой с запятой. Затем смотрим на подсказку, что делать дальше.

Закрытие аргумента

  1. Указываем диапазон первого условия. В нашем случае это графа «Стоимость».

Выбор диапазона

  1. Для того чтобы не было ошибок, дописываем символ «;». Затем в двойных кавычках пишем условие сортировки. Например, в нашем случае это «>20». Также закрываем точкой с запятой. Если вы часто работаете в Excel или планируете там работать – нужно привыкать все аргументы закрывать этим символом.

Исключение ошибок

  1. Далее мы видим подсказку, что нужно проделать те же самые действия, но теперь для второго условия. Их может быть огромное количество. Просто каждый раз необходимо выделять нужный диапазон и затем указывать условие. Выделяем столбец «Статус».

Очередная подсказка

  1. Ставим точку с запятой и пишем в кавычках слово «Продано». В конце нашей формулы обязательно ставим закрывающую скобку.

Вставка точки с запятой

Для завершения работы с редактором функций нажмите на клавишу Enter. Сразу после этого вы увидите результат.

Завершение работы

В нашем случае мы видим, что дорогих товаров у нас 18, а продано из них всего 10.

Заключение

В данной статье были рассмотрены основные возможности редактора Excel для расчета суммы значений в столбцах:

  • через панель инструментов;
  • обычное сложение при помощи одной функции;
  • с учетом одного условия;
  • применение сложных формул.

Если у вас что-то не получилось, возможно вы делаете что-то не так. Большой процент ошибок многие допускают именно из-за синтаксиса, то есть забывают дописывать кавычки или скобки.

Видеоинструкция

Если у вас что-то не получилось или остались какие-нибудь вопросы, ниже прилагается видеоролик, в котором можно увидеть дополнительные замечания к описанным выше инструкциям.

Читайте также:

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Adblock detector